找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
热搜: 活动 交友 discuz
查看: 372|回复: 0

锐捷三层交换命令大全

[复制链接]

30

主题

0

回帖

120

积分

超级版主

积分
120
发表于 2024-6-1 21:11:20 | 显示全部楼层 |阅读模式
1.首先是三层交换机的配置
  Ruijie>enable ------>进入特权模式
  Ruijie#configure terminal ------>进入全局配置模式
  sdk_1(config)#hostname cd12371 ------>配置交换机的名字为sdk_1
  sdk_1(config)#interface vlan 1 ------>进入vlan 1
  sdk_1(config-if)#ip address 192.168.1.245 255.255.255.0 ------>vlan 1设置管理ip
  sdk_1(config-if)#exit ------>退回到全局模式
  sdk_1(config)#line vty 0 4 ------> 进入telnet密码配置模式
  sdk_1(config-line)#login ------>启用需输入密码才能telnet成功
  sdk_1(config-line)#password Lhyj@)!$cd12371 ------> telnet密码设置为123
  sdk_1(config-line)#exit ------> 回到全局配置模式
  sdk_1(config)# enable secret Lhyj@)!$cd12371 ------>配置进入特权模式的密码为123
  sdk_1(config)#enable service web-server ------>全局web功能
  sdk_1(config)#vlan 10 name yunwei ------>
  sdk_1(config)#vlan 20 name yanfa ------>建立各部 门 的vlan
  sdk_1(config)#vlan 30 name fuwu ------>
  sdk_1(config)#interface vlan 10 ------>进入vlan 10
  sdk_1(config-if-VLAN 10)#ip address 172.10.10.254 255.255.255.0 ------>配置各个vlan的地址
  sdk_1(config-if-VLAN 10)#exit
  sdk_1(config)#interface vlan 20 ------>进入vlan 20
  sdk_1(config-if-VLAN 20)#ip address 192.168.20.254 255.255.255.0
  sdk_1(config-if-VLAN 20)#exit
  sdk_1(config)#interface vlan 30 ------>进入vlan 30
  sdk_1(config-if-VLAN 30)#ip address 192.168.30.254 255.255.255.0
  sdk_1(config-if-VLAN 30)#exit
  sdk_1 (config)#service dhcp ---->开启dhcp server功能
  sdk_1 (config)#ip dhcp ping packets 1
  ---->dhcp server分配IP时会先去检测将要分配的IP地址是否已有人使用,如果没人使用则分配,若已有人使用则再分配下一个IP
  sdk_1 (config)#ip dhcp excluded-address 192.168.10.1 192.168.10.100
  sdk_1 (config)#ip dhcp excluded-address 192.168.10.141 192.168.10.254设置地址为:192.168.10.101192.168.10.140ip地址分配给客户端
  sdk_1 (config)#ip dhcp excluded-address 192.168.20.1 192.168.20.100
  sdk_1 (config)#ip dhcp excluded-address 192.168.20.161 192.168.20.254设置地址为:192.168.20.101192.168.20.160ip地址分配给客户端
  sdk_1 (config)#ip dhcp excluded-address 192.168.30.1 192.168.30.100
  sdk_1 (config)#ip dhcp excluded-address 192.168.30.121 192.168.30.254 -设置地址为:192.168.60.101192.168.60.120ip地址分配给客户端
  sdk_1 (config)#ip dhcp pool yunwei ---->新建一个dhcp地址池名为guanli
  sdk_1 (dhcp-config)# lease 0 12 ---->租期时间设置为12 小时
  sdk_1 (dhcp-config)# network 192.168.10.0 255.255.255.0 ----给客户端分配的地址段
  sdk_1 (dhcp-config)# dns-server 61.139.2.69 ---->给客户端分配的DNS
  sdk_1(dhcp-config)# default-router 192.168.10.254
  sdk_1(dhcp-config)#exit
  sdk_1(config-if-FastEthernet 0/1)#no switchport ---->开启路由模式
  sdk_1(config-if-FastEthernet 0/1)#ip address 192.168.2.2 255.255.255.0 ---->配置地址
  sdk_1(config-if-FastEthernet 0/1)#no shutdown ---->开启该接口
  sdk_1(config-if-FastEthernet 0/1)#exit
  2.扩展ACL
  (config)#ip access-list extended listname
  定义命名扩展列表,命名为listname,extended为扩展
  (config-ext-nacl)#deny tcp 192.168.30.0 0.0.0.255 192.168.10.0 0.0.0.255 eq www 拒绝源地址为192.168.30.0网段的IP访问目的地址为192.168.10.0网段的WWW服务
  注:deny:拒绝通过,可选:deny(拒绝通过)permit(允许通过)
  tcp: 协议名称,协议可以是udp, ipeigrp, gre, icmp, igmp, igrp等等。
  192.168.10.0 0.0.0.255:源地址及源地址通配符
  192.168.30.0 0.0.0.255:目的地址及目的地址通配符
  eq:操作符(lt-小于,eq-等于,gt-大于,neg-不等于,range-包含)
  www:端口号,可使用名称或具体编号
  可以使用的协议名称(或编号)和端口名称(或编号)请打?查询。
  (config-ext-nacl)#permit ip any any 允许其它通过
  (config-ext-nacl)#e1.首先是三层交换机的配置
  Ruijie>enable ------>进入特权模式
  Ruijie#configure terminal ------>进入全局配置模式
  sdk_1(config)#hostname cd12371 ------>配置交换机的名字为sdk_1
  sdk_1(config)#interface vlan 1 ------>进入vlan 1
  sdk_1(config-if)#ip address 192.168.1.245 255.255.255.0 ------>vlan 1设置管理ip
  sdk_1(config-if)#exit ------>退回到全局模式
  sdk_1(config)#line vty 0 4 ------> 进入telnet密码配置模式
  sdk_1(config-line)#login ------>启用需输入密码才能telnet成功
  sdk_1(config-line)#password Lhyj@)!$cd12371 ------> telnet密码设置为123
  sdk_1(config-line)#exit ------> 回到全局配置模式
  sdk_1(config)# enable secret Lhyj@)!$cd12371 ------>配置进入特权模式的密码为123
  sdk_1(config)#enable service web-server ------>全局web功能
  sdk_1(config)#vlan 10 name yunwei ------>
  sdk_1(config)#vlan 20 name yanfa ------>建立各部 门 的vlan
  sdk_1(config)#vlan 30 name fuwu ------>
  sdk_1(config)#interface vlan 10 ------>进入vlan 10
  sdk_1(config-if-VLAN 10)#ip address 172.10.10.254 255.255.255.0 ------>配置各个vlan的地址
  sdk_1(config-if-VLAN 10)#exit
  sdk_1(config)#interface vlan 20 ------>进入vlan 20
  sdk_1(config-if-VLAN 20)#ip address 192.168.20.254 255.255.255.0
  sdk_1(config-if-VLAN 20)#exit
  sdk_1(config)#interface vlan 30 ------>进入vlan 30
  sdk_1(config-if-VLAN 30)#ip address 192.168.30.254 255.255.255.0
  sdk_1(config-if-VLAN 30)#exit
  sdk_1 (config)#service dhcp ---->开启dhcp server功能
  sdk_1 (config)#ip dhcp ping packets 1
  ---->dhcp server分配IP时会先去检测将要分配的IP地址是否已有人使用,如果没人使用则分配,若已有人使用则再分配下一个IP
  sdk_1 (config)#ip dhcp excluded-address 192.168.10.1 192.168.10.100
  sdk_1 (config)#ip dhcp excluded-address 192.168.10.141 192.168.10.254设置地址为:192.168.10.101192.168.10.140ip地址分配给客户端
  sdk_1 (config)#ip dhcp excluded-address 192.168.20.1 192.168.20.100
  sdk_1 (config)#ip dhcp excluded-address 192.168.20.161 192.168.20.254设置地址为:192.168.20.101192.168.20.160ip地址分配给客户端
  sdk_1 (config)#ip dhcp excluded-address 192.168.30.1 192.168.30.100
  sdk_1 (config)#ip dhcp excluded-address 192.168.30.121 192.168.30.254 -设置地址为:192.168.60.101192.168.60.120ip地址分配给客户端
  sdk_1 (config)#ip dhcp pool yunwei ---->新建一个dhcp地址池名为guanli
  sdk_1 (dhcp-config)# lease 0 12 ---->租期时间设置为12 小时
  sdk_1 (dhcp-config)# network 192.168.10.0 255.255.255.0 ----给客户端分配的地址段
  sdk_1 (dhcp-config)# dns-server 61.139.2.69 ---->给客户端分配的DNS
  sdk_1(dhcp-config)# default-router 192.168.10.254
  sdk_1(dhcp-config)#exit
  sdk_1(config-if-FastEthernet 0/1)#no switchport ---->开启路由模式
  sdk_1(config-if-FastEthernet 0/1)#ip address 192.168.2.2 255.255.255.0 ---->配置地址
  sdk_1(config-if-FastEthernet 0/1)#no shutdown ---->开启该接口
  sdk_1(config-if-FastEthernet 0/1)#exit
  2.扩展ACL
  (config)#ip access-list extended listname
  定义命名扩展列表,命名为listname,extended为扩展
  (config-ext-nacl)#deny tcp 192.168.30.0 0.0.0.255 192.168.10.0 0.0.0.255 eq www 拒绝源地址为192.168.30.0网段的IP访问目的地址为192.168.10.0网段的WWW服务
  注:deny:拒绝通过,可选:deny(拒绝通过)permit(允许通过)
  tcp: 协议名称,协议可以是udp, ipeigrp, gre, icmp, igmp, igrp等等。
  192.168.10.0 0.0.0.255:源地址及源地址通配符
  192.168.30.0 0.0.0.255:目的地址及目的地址通配符
  eq:操作符(lt-小于,eq-等于,gt-大于,neg-不等于,range-包含)
  www:端口号,可使用名称或具体编号
  可以使用的协议名称(或编号)和端口名称(或编号)请打?查询。
  (config-ext-nacl)#permit ip any any 允许其它通过
  (config-ext-nacl)#end 返回
  (config)#interface vlan 10 进入端口配置模式
  (config-if)# ip access-group listname in 访问控制列表在端口下in方向应用;可选:in(入栈)out(出栈)
  (config-if)#end 返回
  注:配置ACL时,若只想对其中部分IP进行限制访问时,必须配置允许其流量通过,否则设备只会对限制IP进行处理,不会对非限制IP进行允许通过处理。nd 返回
  (config)#interface vlan 10 进入端口配置模式
  (config-if)# ip access-group listname in 访问控制列表在端口下in方向应用;可选:in(入栈)out(出栈)
  (config-if)#end 返回
  注:配置ACL时,若只想对其中部分IP进行限制访问时,必须配置允许其流量通过,否则设备只会对限制IP进行处理,不会对非限制IP进行允许通过处理。

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|Archiver|手机版|小黑屋|BECKMAN ( 蜀ICP备20004689号 )

GMT+8, 2024-6-21 14:44 , Processed in 0.038324 second(s), 22 queries .

Powered by Discuz! X3.5 Licensed

© 2001-2024 Discuz! Team.

快速回复 返回顶部 返回列表