找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
热搜: 活动 交友 discuz
查看: 368|回复: 0

华为交换机常用命令集合

[复制链接]

30

主题

0

回帖

120

积分

超级版主

积分
120
发表于 2024-6-1 21:10:19 | 显示全部楼层 |阅读模式
System-view  进去系统视图模式,可以简写为sys
Sysname xxx   给设备命名为xxx
Quit          退出当前模式
一..配置文件相关命令:
[]------->视图模式下
1.Display current-configuration    显示当前生效的配置,可以简写为dis cur
sysname jcg     设备名字jcg
#
vlan batch 10 20      批量创建vlan(虚拟局域网),这里是创建vlan10vlan20,  如果是10 to 20 或者10-20就是创建vlan10vlan11......vlan20
#
stp disable      STPSpanning Tree Protocol)是生成树协议的英文缩写。该协议可应用于在网络中建立树形拓扑,消除网络中的环路,并且可以通过一定的方法实现路径冗余,但不是一定可以实现路径冗余
#
multicast routing-enable          启用组播(在发送者和每一接收者之间实现点对多点网络连接
#
cluster enable     主要是用来开启HGMP协议的。
1.HGMP就是Huawei Group Management Protocol的缩写,即华为组管理协议,它是华为的私有协议,对该协议有解释权和修改权。
2.一种实现管理进程对代理进程下的进行集中管理和二层多播组控制的通 信协议。其主要结构是:一个管理进程,同时管理其下的许多代理进程。在管理进程和代理进程上同时都运行HGMP协议。HGMP协议不支持存在环路的网络
ntdp enable            NTDP是用来收集网络拓扑信息的协议。NTDP 为集群管理提供可加入集群的设备信息,收集指定跳数内的交换机的拓扑信息。
ndp enable             NDPneighbor discovery protocol)是用来发现邻接点相关信息的协议。ndp运行在数据链路层,因此可以支持不同的网络层协议。
#
drop illegal-mac alarm      投下非法mac的警报
#
diffserv domain default           命令用来创建一个DiffServ域并进入对应的DS域视图,或进入已存在的DS域视图(这里是创建系统预先设定的缺省DiffServ)
diffserv domain { default | ds-domain-name }
undo diffserv domain ds-domain-name(指定DiffServ域的名称)
#
drop-profile default      
#
aaa         一般是用来给网络设备认证用的,可以提供设备的安全性
authentication-scheme default     验证   
authorization-scheme default      授权
accounting-scheme default        记账
domain default                  // 普通用户的默认域
domain default_admin            // 管理人员的默认域
local-user admin password simple admin    本地用户admin密码admin
local-user admin service-type http         本地用户admin服务类型http
#
interface Vlanif1           进入VLAN1的逻辑接口
#
interface Vlanif10          进入VLAN10的逻辑接口
ip address 1.1.1.1 255.255.255.0
pim sm                   协议无关组播
#
interface Vlanif20
ip address 2.2.2.1 255.255.255.0
pim sm
igmp enable          Internet 组管理协议
#
interface MEth0/0/1      表示这个端口是设备主控板上面的管理网口,是个百兆的端口
#
interface GigabitEthernet0/0/1         千兆接口
port hybrid pvid vlan 10              端口的虚拟局域网ID10,模式为hybrid模式
port hybrid untagged vlan 10          untagedtaged是交换机将包发出去时是否加上vlan号作为标识
access模式的端口只属于某一个vlan,用于连接电脑
trunk模式的端口可以传输多个vlan的信息,用着交换机连交换机,或交换机连路由器
hybrid模式的端口既可以连电脑,也可以连交换机和路由器(是access模式和trunk模式的集合)
#
interface GigabitEthernet0/0/2
port hybrid pvid vlan 20
port hybrid untagged vlan 20
#
interface GigabitEthernet0/0/3
port hybrid pvid vlan 20
port hybrid untagged vlan 20
#
interface GigabitEthernet0/0/4
port hybrid pvid vlan 20
port hybrid untagged vlan 20
#
interface GigabitEthernet0/0/5
port hybrid pvid vlan 20
port hybrid untagged vlan 20
#
interface GigabitEthernet0/0/6
port hybrid pvid vlan 20
port hybrid untagged vlan 20
#
interface GigabitEthernet0/0/7
#
interface GigabitEthernet0/0/8
#
interface GigabitEthernet0/0/9
#
interface GigabitEthernet0/0/10
#
interface GigabitEthernet0/0/11
#
interface GigabitEthernet0/0/12
#
interface GigabitEthernet0/0/13
#
interface GigabitEthernet0/0/14
#
interface GigabitEthernet0/0/15
#
interface GigabitEthernet0/0/16
#
interface GigabitEthernet0/0/17
#
interface GigabitEthernet0/0/18
#
interface GigabitEthernet0/0/19
#
interface GigabitEthernet0/0/20
#
interface GigabitEthernet0/0/21
#
interface GigabitEthernet0/0/22
#
interface GigabitEthernet0/0/23
#
interface GigabitEthernet0/0/24
#
interface NULL0
#
igmp
timer query 300       定时查询时间为300
#
pim
c-rp Vlanif10
#
user-interface con 0     用户接口con 0
user-interface vty 0 4    vty 0 4代表有5VTY线路 由04vty:虚拟终端,一种网络设备的连接方式)
#
return
2.display saved-configuration    显示当前flash配置文件,即下次上电启动时所用的配置文件
3.reset saved-configuration    擦除旧的配置文件
4.reboot                交换机重启
5.display version          显示系统版本信息
二.基本配置
1.[jcg]Super password xxx?    修改特权用户密码
2.[jcg]sysname xxx          交换机命名
3.[jcg]interface xxx     进去接口视图   
xx
Eth-Trunk        Ethernet-Trunk interface
  GigabitEthernet  GigabitEthernet interface
  LoopBack         LoopBack interface
  MEth             MEth interface
  NULL             NULL interface
  Tunnel           Tunnel interface
  Vlanif           Vlan interface
4.[jcg]interface vlan xx    进入接口视图
5.[jcg-vlan-interfacex]ip address 192.168.10.2 255.255.255.0     配置vlanip地址
6.[jcg]ip route-static 0.0.0.0 0.0.0.0 10.65.1.2   静态路由====网关
用户视图<>  与交换机建立连接即进入
系统视图[]   system-view 进入系统视图。
以太网端口视图[Quidway-Ethernet0/1]:在系统视图下键入interface?ethernet?0/1
display version   显示版本信息
display cpu-usage    查看cpu的使用率
display memory-usage   查看内存使用率
display int g0/0/1    查看具体某一个接口的信息
display int brief  查看各接口运行状态
display current-configuration   查看当前配置信息
display  vlan   查看vlan 信息
display acl all  查看访问控制列表信息
display logbuffer  查询日志信息
display?environment  查看温度信息
display ndp 显示交换机端口的详细配置信息。
display arp  查看arp
display snmp-agent community 检查SNMP默认通信字符串有否修改   
display ip routing-table  显示路由信息

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|Archiver|手机版|小黑屋|BECKMAN ( 蜀ICP备20004689号 )

GMT+8, 2024-6-21 16:46 , Processed in 0.038140 second(s), 22 queries .

Powered by Discuz! X3.5 Licensed

© 2001-2024 Discuz! Team.

快速回复 返回顶部 返回列表